I have items that can be installed and uninstalled. I have a list that contains all the items that were installed one more time than they were uninstalled.
My first guess to describe the list is: “The list contains items that were installed once more than uninstalled”. To myself that sounds wrong. It sounds like a literal translation from german (I’m german) but I can’t think of a way that sounds right.
How would you say this correctly?
EDIT: The phrase is a comment in source code. At first sight the code looks more complicated than it needs to be. The complete comment is:
remove() (in contrast to removeAll()) only removes one instance of a component if the component is in the list multiple times. This results in a list that only contains components that were installed once more than uninstalled.
To be honest, your original phrasing “The list contains items that were installed once more than uninstalled” sounds fine. Unless it’s completely obvious, I would probably add something to explain why you’re choosing to phrase it in that way, though, rather than just say “These items are currently installed”.